Divi WordPress Theme

Fatal error: Allowed memory size of 33554432 bytes exhausted in http.php

Topic: Fatal error: Allowed memory size of 33554432 bytes exhausted in http.php  (Read 45145 times)

Offline Wordpress

  • Newbie
  • *
  • Posts: 2
  • iTrader: +0/-0
    • View Profile
I am getting following error message in Wordpress while trying to upgrade automatically via my dashboard:

Get this error when i try to use automatic upgrade via my dashboard:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2355395 bytes) in /home/users/public_html/wp-includes/http.php on line 1327

Am I doing wrong?

Wordpress
VPS Hosting - AccuWebHosting

Offline Kailash

  • Web Hosting Master
  • *****
  • Administrator
  • Posts: 604
  • iTrader: +153/-0
    • View Profile
Re: Fatal error: Allowed memory size of 33554432 bytes exhausted in http.php
« Reply #1 on: September 04, 2009, 12:16:06 AM »
You are getting this error because your blog exceeds allowed PHP memory. There are some work around to increase the value for PHP memory:

[1] You can contact your host to raise limit for php_memory.

[2] You can add following line in your .htaccess:

php_value memory_limit 64M


This will not work if suPHP is enabled on your server. If suPHP is enabled on your server then you will need to put php.ini in the root of your domain and modify the following line:

memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

[3] You can also raise PHP memory from wp-config.php file. Just add the following line after

define(’WP_MEMORY_LIMIT’, ‘64M’);


If the problem still persists, you can contact your host for further assistance.

Regards,

Kailash
Divi WordPress Theme
Tags: