Divi WordPress Theme

Topic: assembly does not allow partially trusted callers  (Read 5920 times)

Offline scott

  • New Member
  • *
  • Posts: 33
  • iTrader: +0/-0
    • View Profile
assembly does not allow partially trusted callers
« on: January 19, 2007, 10:22:11 AM »
Hello,

I have developed an application using Asp.Net and MySQL. It is working fine in my local system but when I have uploaded it to my web site but it is giving me below error..

System.Security.SecurityException: That assembly does not allow partially trusted callers.

I am using MySql.Data.dll.

Any help would be appreciated.

Thanks,

Scott
« Last Edit: January 01, 1970, 05:30:00 AM by scott »
VPS Hosting - AccuWebHosting

Offline Kailash

  • Web Hosting Master
  • *****
  • Administrator
  • Posts: 652
  • iTrader: +153/-0
    • View Profile
(No subject)
« Reply #1 on: January 20, 2007, 02:32:10 PM »
Hi Scott,

Welcome to the forum!

It seems that you have developed your application in full trust level and your hosting provider doesn’t allow full trust level on their server. You have to either modify your application to run under the trust level which is set on the server (Most of the hosting providers set the medium trust level on the server for security reasons) or you have to contact your hosting provider to change the trust level on the server.

If you modify your application then you have to recompile your DLL file ‘MySql.Data.dll’ and have to upload it again.

Thanks,
« Last Edit: March 03, 2007, 12:40:49 PM by Kailash »

Offline scott

  • New Member
  • *
  • Posts: 33
  • iTrader: +0/-0
    • View Profile
(No subject)
« Reply #2 on: January 21, 2007, 08:17:25 AM »
Thanks Kailash,

It fixed... :D

Scott
« Last Edit: January 01, 1970, 05:30:00 AM by scott »
Shopify Divi WordPress Theme
Tags: