Divi WordPress Theme

Topic: Incorrect integer value: ” for column ‘id’ at row 1  (Read 1320 times)

Offline Rick

  • New Member
  • *
  • Posts: 25
  • iTrader: +0/-0
    • View Profile
Incorrect integer value: ” for column ‘id’ at row 1
« on: May 01, 2015, 04:59:19 PM »
I am installing third party CMS (built in PHP and MySQL) but during installation, I got following message:

My SQL Error 1048 column description cannot be null
Incorrect integer value: ” for column ‘id’ at row 1
Field ‘description’ doesn’t have a default value


I have tried 2-3 times to install it without any success. Also this is a fresh installation so I am not sure why it is telling "Field ‘description’ doesn’t have a default value".

Any help would be appreciated!

- Rick
VPS Hosting - AccuWebHosting

Offline Kailash

  • Web Hosting Master
  • *****
  • Administrator
  • Posts: 604
  • iTrader: +153/-0
    • View Profile
Re: Incorrect integer value: ” for column ‘id’ at row 1
« Reply #1 on: May 01, 2015, 05:29:32 PM »
Most likely you are facing the problem due to MySQL strict mode. You can refer our article on Disable MySQL strict mode to disable it. Please note, you will need server's root/administrative access to make this change.

- Kailash

Offline WebhostingTalk

  • Junior Guru
  • *****
  • Premium Member
  • Posts: 54
  • iTrader: +2/-0
    • View Profile
Re: Incorrect integer value: ” for column ‘id’ at row 1
« Reply #2 on: May 04, 2015, 03:22:11 PM »
I had similar issue with one of the third party PHP/MySQL script and the root cause of the issue was MySQL strict mode. MySQL server was configured with strict mode.
Divi WordPress Theme
Tags: