EasyApache 3.26.9 Released

EasyApache 3.26.9 was released with PHP versions 5.4.34 and 5.5.18 and libxml2 version 2.9.2. This release addresses vulnerabilities related to CVE-2014-3669, CVE-2014-3670, CVE-2014-3668, CVE-2014-3660, and CVE-2014-0191 by fixing bugs in the Core, Exif, and XMLRPC modules and in libxml2. It is strongly recommended all PHP 5.4 users to upgrade to PHP version 5.4.34 and all PHP 5.5 users to upgrade to version 5.5.18.

WHMCS Complete Billing and Support

AFFECTED VERSIONS

All versions of PHP 5.4 through version 5.4.33 and PHP 5.5 through version 5.5.17.
All versions of libxml2 before EasyApache version 3.26.9.

SECURITY RATING

The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2014-3669 – MEDIUM

PHP 5.4.34
Fixed bug in the Core module related to CVE-2014-3669

PHP 5.5.18
Fixed bug in the Code module related to CVE-2014-3669

CVE-2014-3670 – MEDIUM

PHP 5.4.34
Fixed bug in Exif module related to CVE-2014-3670

PHP 5.5.18
Fixed bug in Exif module related to CVE-2014-3670

CVE-2014-3668 – MEDIUM

PHP 5.4.34
Fixed bug in XMLRPC related to CVE-2014-3668

PHP 5.5.18
Fixed bug in XMLRPC related to CVE-2014-3668

CVE-2014-3660 – MEDIUM

libxml2
Fixed bug related to CVE-2014-3660

CVE-2014-0191 – MEDIUM

libxml2
Fixed bug in the libxml2 library related to CVE-2014-0191.

SOLUTION

cPanel, Inc. has released EasyApache 3.26.9 with updated versions of PHP 5.4.34, PHP 5.5.18 and libxml2 2.9.2 to correct these issues. Unless you have disabled EasyApache updates, EasyApache updates automatically. Run EasyApache to rebuild your profile with the latest version of PHP and libxml2.

Posted in Security.