WordPress team has released a critical security update for all previous versions and it is strongly encourage that you update your WordPress version to WordPress 4.1.2.
WordPress versions 4.1.1 and earlier are affected by a critical cross-site scripting vulnerability, which could enable anonymous users to compromise a site.
They have also fixed three other security issues as follow:
 In WordPress 4.1 and higher, files with invalid or unsafe names could be uploaded.
 In WordPress 3.9 and higher, a very limited cross-site scripting vulnerability could be used as part of a social engineering attack.
 Some plugins were vulnerable to an SQL injection vulnerability.
A number of plugins also released security fixes yesterday. Keep everything updated to stay secure. If you’re a plugin author, please read this post to confirm that your plugin is not affected by the same issue.